CENTOS 7 安装perl环境后遇到的一个小问题

2018年07月15日 377点热度 0人点赞 0条评论

首先感谢zhang6622056的专栏yangyangrenren的专栏的文章。

为了安装17ce的客户端,需要安装perl。

第一部分安装perl

前言

最近开始学习linux虚拟机相关的东西,在刚刚开始的路上就是各种曲折,网络问题,装载问题,由于vmware tools需要perl环境的支持,于是安装perl环境。还没有正式开始学习要学的东西就已经被环境搞得很头疼,总结如下

安装perl支持

yum install perl* (yum安装perl相关支持)
yum install cpan (perl需要的程序库,需要cpan的支持,详细自行百度)

下载perl并安装

wget http://www.cpan.org/src/5.0/perl-5.16.1.tar.gz
tar -zxvf perl-5.16.1.tar.gz
./Configure -des -Dprefix=/usr/local/perl

编译安装

make
make test
make install

注意事项

一个干净的centos系统是没有相关支持的,以至于在操作过程中会出现各类异常,像是编译,像是wget command not found等,整个make的过程是时间非常长的,需要耐心等待。

问题1:wget不被识别

yum install wget

问题2:make命令不被识别

yum install gcc
reboot
再次make
perl -v

第二部分,运行17ce后遇到找不到libbz2.so.1.0

首先看一下/usr/lib64/里面有没有,没有的话网上找一个下载。这里提供了。libbz2.so.1.0

做一个软链接libbz2.so.1.0,指向已经有的libbz2.so.1.0.6

 

LoveXu

保持饥渴的专注,追求最佳的品质

文章评论